Troubleshooting
Problem
After a new interim fix or fix pack is applied to an environment, which previously had the Log4JSafeAgent.jar remediation applied, no reports are able to be run in Dynamic Query Mode. In addition, data sources are unable to be tested successfully.
Symptom
Error messages running reports or testing data sources:
DPR-ERR-2072 Unable to load balance a request with absolute affinity, most likely due to a failure to connect to the remote dispatcher. See the remote dispatcher detailed logs for more information. Check the health status of the installed system by using the dispatcher diagnostics URIs
DPR-ERR-2002 Unable to execute the request because there was no process available within the configured time limit.
Error message in the cogaudit.log:
Audit.RTUsage.qs.XQE.V5DataServer StartService QueryService failed to start with the following command-line arguments: [/path/to/ibm-jre/jre/bin/java, -d64, -Xms8192m, -Xmx8192m, -XX:MaxNewSize=4096m, -XX:NewSize=4096m, -server, -XX:+DoEscapeAnalysis, -javaagent:../webapps/p2pd/WEB-INF/lib/log4jSafeAgent2021.jar, -XX:+UseCompressedOops, -verbose:gc, -Xloggc:/path/to/cognos/logs/XQE/dq_verbosegc.log, -XX:+UseConcMarkSweepGC, -XX:+UseParNewGC, -XX:SurvivorRatio=8, -XX:TargetSurvivorRatio=90, -XX:MaxTenuringThreshold=15, -XX:OnOutOfMemoryError=rm -f /path/to/cognos/data/.xqe.%p > /dev/null, -DCOG_ROOT=/path/to/cognos, -DParentProcessID=11259, -Dorg.xerial.snappy.tempdir=/path/to/cognos/temp, -Dcubingservices_home=/path/to/cognos/v5dataserver, -Dcubingservices_data=/path/to/cognos/data, -DParentProcessPort=46172, -Djava.library.path=/path/to/cognos/bin64:/path/to/cognos/bin64/../drivers:, -Djava.rmi.server.hostname=<hostname>, -DenableTraceServer, -ea, -Dorg.dom4j.QName.singleton.strategy=org.dom4j.util.PerThreadSingleton, -Dorg.dom4j.DocumentFactory.singleton.strategy=org.dom4j.util.PerThreadSingleton, -javaagent:bin/tools/ws-javaagent.jar, -jar, bin/tools/ws-server.jar, dataset-service] with console output: Error opening zip file or JAR manifest missing : ../webapps/p2pd/WEB-INF/lib/log4jSafeAgent2021.jar Error occurred during initialization of VM agent library failed to init: instrument
Cause
When upgrading an environment which was manually remediated, the following actions occur:
1) The bootstrap_wlp_<os>.xml file is over-written during the upgrade, which removes the Log4JSafeAgent2021.jar reference
2) The Log4JSafeAgent2021.jar file is removed from the <COGNOS INSTALL>\webapps\p2pd\WEB-INF\lib folder as it is not included in the file preservation rules.
3) The xqe.config.custom.xml file is preserved due to being included in the file preservation rules, and this retains the reference to the Log4JSafeAgent2021.jar file which was added during manual remediation.
The issue results from a combination of items 2 and 3, because the Query Service is trying to load the Log4JSafeAgent2021.jar file during initialization, which then fails due to the file being missing.
Environment
Cognos Analytics 11.1.x where the manual Log4J remediation steps have been followed
Subsequent application of a higher interim fix (usually 11.1.7 IF9) or fix pack (usually 11.1.7 FP5)
Diagnosing The Problem
1) Check cogaudit.log and confirm that the error exists, and that it is referencing the Log4JSafeAgent2021.jar
2) Verify that there is no Log4JSafeAgent2021.jar file present in <COGNOS INSTALL>\webapps\p2pd\WEB-INF\lib
3) Verify that the <COGNOS INSTALL>\configuration\xqe.config.custom.xml file still exists
Resolving The Problem
1) Rename the xqe.config.custom.xml to xqe.config.custom.xml.backup
2) Restart Cognos Analytics
Followup actions include comparing the xqe.config.custom.xml.backup file with the original xqe.config.xml file, to ensure that no other customizations are impacted by the removal of the custom configuration file. If there are other customizations present, please refer to the original document for the manual remediation, and revert those steps.
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m0z0000001josAAA","label":"Administration-\u003ECustomization"}],"ARM Case Number":"TS009650184","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]
Was this topic helpful?
Document Information
Modified date:
18 June 2022
UID
ibm16596411