Troubleshooting
Problem
In the Databases tab of the Planning Analytics Workspace administration page, an "Agent unreachable" error is displayed at the top, and a "Cannot display resource information" error is displayed for each monitored TM1 Server database.
Symptom
Kate-agent service is running
We are able to open PAA service API site
https://TM1_FQDN:9012/pakate-agent/
In PAA messages.logs located in <INSTAL_DIR>\tm1_64\paa_agent\wlp\usr\servers\kate-agent\logs we can see entries like
err] ERROR:status.py:Error while running get-wmiobject service command: get-wmiobject : Invalid class "win32_service"
At line:1 char:14
+ chcp 65001 ; get-wmiobject win32_service |where pathname -like '*tm1s ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidType: (:) [Get-WmiObject], ManagementException
+ FullyQualifiedErrorId : GetWMIManagementException,Microsoft.PowerShell.Commands.GetWmiObjectCommand
[err] ERROR:status.py:Error getting the Server Services Details: index out of range: 0
Traceback (most recent call last):
File "kateagent/scripts\status.py", line 297, in get_win_services
name_index = services[0].find("name")
IndexError: index out of range: 0
[err] ERROR:status.py:Error while running wmic process: Node
When try to run
PS C:\Windows\system32> get-wmiobject win32_service |where pathname -like '*i*'
you will get
get-wmiobject : Invalid class "win32_service"
At line:1 char:1
+ get-wmiobject win32_service |where pathname -like '*i*'
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidType: (:) [Get-WmiObject], ManagementException
+ FullyQualifiedErrorId : GetWMIManagementException,Microsoft.PowerShell.Commands.GetWmiObjectCommand
Cause
The OS is unable to run get-wmiobject and this cause that service is not running correctly.
Resolving The Problem
Register missing class with
mofcomp %windir%\system32\wbem\cimwin32.mof
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSCTEW","label":"IBM Planning Analytics Local"},"ARM Category":[{"code":"a8m50000000KzIzAAK","label":"Planning Analytics-\u003EPlanning Analytics Workspace"},{"code":"a8m50000000KzL5AAK","label":"Planning Analytics-\u003EPlanning Analytics Workspace-\u003EAdministration"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]
Was this topic helpful?
Document Information
Modified date:
03 June 2022
UID
ibm16592165