Troubleshooting
Problem
Data Gateways (DG) status in QRadar on Cloud (QRoC) is monitored by the QRadar® on Cloud Self Serve app. A cloud icon appears in the upper right of the Console's GUI but does not list the Data Gateway status.
Symptom
When administrators click the cloud icon, it displays the error "Unable to list managed hosts from API."
Cause
The browser’s cookies do not refresh that causes communication problems with the API. This problem affects the retrieval of the actual status of the Data Gateways.
Environment
QRadar on Cloud
Diagnosing The Problem
- Log in to the QRadar on Cloud Console GUI as an administrator user.
- Click the cloud icon in the upper right of the Console's GUI. It displays the error "Unable to list managed hosts from API."
- SSH to a Data Gateway in the deployment as the root the user. See the section "Data Gateway(DG) Administration" in the QRadar on Cloud FAQ to configure it.
- Verify the Data Gateway downloads the database dumps successfully.
[root@<Data Gateway Hostname> ~]# /opt/qradar/bin/replication.pl -download Downloading updates to the database. [replication] [INFO] Using <Data Gateway IP Address> as our local IP. [replication] [INFO] Downloading and applying latest database dumps from the console. [replication] [INFO] Downloading and applying latest database dumps from the console.
If the Data Gateway is downloading successfully the database dumps, administrators can use the steps in this article to resolve the problem. However, if the database dumps are not downloaded successfully, follow the steps in this article.
Resolving The Problem
- Open your web browser.
- Clear your web browser cache and cookies. For instructions, see your web browser documentation.
Results
The Data Gateways statuses are now displayed correctly. If the error persists, the administrators can contact QRadar Support for assistance.
Related Information
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSBQAC","label":"IBM Security QRadar SIEM"},"ARM Category":[{"code":"a8m0z000000cwsyAAA","label":"Admin Tasks"}],"ARM Case Number":"","Platform":[{"code":"PF016","label":"Linux"}],"Version":"All Versions"}]
Was this topic helpful?
Document Information
Modified date:
23 May 2022
UID
ibm16587771