IBM Support

Monitoring passive/active SSP-CM showing duplicates entries on Web Console

Troubleshooting


Problem

We are monitoring two SSP Engines in Control Center,  but we see 4 engines in the dashboard not 2.
Some active some unknown status.
The two SSP engines are an active/passive setup.

Symptom

Control Center shows duplicate entries of the SSP engines which different statuses.
Engine_01(active)
Engine_01 (unknown status)
Engine_02(active)
Engine_02 (unknown status).

Cause

Monitoring two different SSP's, but both are named the default of SSP-CM in SSP global definition.

When SSP sends an OSA, CC adds the servers if not added already, when within the heartbeat interval it doesn't get the response back, Control Center Declares the SSP is down and hence the status of the Engines as unknown for that particular SSPCm.

In your case of failover, you are switching to SSPcm that is running on a completely different address/hostname, hence Control Center is treating it as a different server and add that server as a new one which is expected behavior.

Since Control Center depends on the SSPcm sending the OSA for the status of Engine or adapters configured with the CMs. It will add another SSPcm server when Control Center will receive OSA signal coming from the IP/hostname not present already to the CC.

Diagnosing The Problem

Drill down in the Web Console on the SSP Engine and you will see each host name/IP address for the two different engines are different.
Both are named SSP-CM because of naming on SSP, but drill down will show one is kept in database as SSP-CM1.

Resolving The Problem

Change the name of the SSP-CM being sent to Control Center by altering the value in SSP global settings.

This way you can distinguish between the SSP servers and know which is up and which is down in Control Center.

To remove the OSA type servers such as Global Mailbox or SSP added via OSA dynamic discovery. These servers can be deleted from the Java/Swing Console only.

Please follow the below steps to remove them:

  1. Do a fresh login to the Java console.
  2. On the left-hand side panel where you would see all the servers, On the top, you should notice there are two options as Servers and Groups
  3. Click on Groups
  4. You should see all the server groups in the list.
  5. Scroll the list and then Expand All SSP-OSA servers, you should see all the SSP servers(OSA) whether they are Up or Down.
  6. Right Click on the desired server you wish to delete, and then click on Remove Server...

Following these steps should delete the server from the Java console and from the Web Console as well.

6.2.1.0 iFix09 Now can to be deleted through the Web Console

14. LS-165 (2022-10-10)

Description of issue: No option to delete SSP and GM servers from the Web Console UI added dynamically via OSA.  To delete those OSA-added servers (SSP and GM), you need to log in to JAVA/Swing/Classic Console and navigate to Server groups and then right-click on the server you want to delete.     

Description of fix: Added remove server option in web UI OSA Server List.

Document Location

Worldwide

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Document Information

Modified date:
15 March 2023

UID

ibm16586646