Troubleshooting
Problem
There are times when a task might have an associated document or doclink attached. The document should also display in the Work Order as one of the documents associated with the record. However this is not always the case.
Symptom
The documents attached to a Work Order Task should show in the Work Order record.
Cause
This is because the relationship to the Work Order object does not include the Task record in the where clause.
Environment
Maximo Asset Management 7.6.1.2
Maximo Application Suite 8.7
Diagnosing The Problem
These are the steps required to identify the problem.
Work Order Tracking - > NEW -> WO001
TAB Plans -> New Row
Task 10, Add Attachment -> VersionfileSample.txt
TAB Work Order
View Attachments -> No values returned
TAB Plans -> New Row
Task 10, Add Attachment -> VersionfileSample.txt
TAB Work Order
View Attachments -> No values returned
Resolving The Problem
The issue can be resolved by having the necessary relationship clause for the Work Order to retrieve Doclinks from the tasks as well.
The necessary steps to resolve the issues are as follows:
Go to Database Configuration -> WORKORDER -> TAB Relationships
Filter for DOCLINKS
The Where Clause would indicate the search that would find the records.
The following line needs to be included at the end:
or (ownertable='WOACTIVITY' and ownerid in (select workorderid from workorder where parent=:wonum and istask=1 and siteid=:siteid))
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSRHPA","label":"IBM Maximo Application Suite"},"ARM Category":[{"code":"a8m3p000000hBABAA2","label":"Maximo Application Suite->MAS Applications"}],"ARM Case Number":"TS009095026","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]
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Document Information
Modified date:
05 May 2022
UID
ibm16579433