IBM Support

QRadar: Installation or removal of application fails with error "another preview/install/uninstall task is currently in process"

Troubleshooting


Problem

Administrators who try install or uninstall applications or content packs might face the error "another preview/install/uninstall task is currently in process". In this state, applications and content packs cannot be installed by using the Extension Management.

Symptom

In the Extensions Management menu, after an application or content pack file is installed, the following error is displayed:

Figure01

Cause

A previous application or content pack failed to be installed or removed.

Environment

QRadar 7.4.0 and later.

Diagnosing The Problem

The issue can be verified in 2 ways (GUI and CLI).

In the GUI

  1. Log in to the QRadar Console GUI as the administrator user.
  2. Click the Admin tab.
  3. Click the Extensions Management menu.

    Figure02
  4. In the Extensions Management menu, click Add.
  5. Browse the application or content pack package.
  6. Select the "Install immediately" box.
  7. Click Add.

    Figure03
  8. The error "another preview/install/uninstall task is currently in process" shows up.

In the CLI

  1. Log in to the QRadar Console as the root user.
  2. Run the following psql command to check what is the current task blocking the installation or removal.
    Note: The following command displays only the conflicting entries that might cause the issue.
     
    psql -U qradar -c "select hub_id,content_status,id from content_package where content_status not in (3,6,9);"
                           hub_id                        | content_status |  id
    -----------------------------------------------------+----------------+-----
     IBMQRadar:IBMContentPackageInternalBaseMaint        |              5 |  601
     IBMQRadar:Cyber Adversary Framework Mapping Content |              1 |  301
     IBMQRadar:Tuning                                    |              8 |  201
    

Resolving The Problem

  1. Log in to the QRadar Console as the root user.
  2. Back up the content_package table.
    1. Create the backup directory.
      mkdir -p /store/IBM_Support/
    2. Back up the table.
      pg_dump -U qradar -t content_package --inserts -f /store/IBM_Support/content_package.sql-$(date +%F)
  3. Run the psql command in the "Diagnosing the Problem" section and make note of each ID.
  4. Update the content_package table and set the conflicting IDs in the content_status column to 6 (uninstalled status).
    Note: When multiple entries are listed, rerun the command for each ID in the list.
    psql -U qradar -c "update content_package set content_status = 6 where id='<ID>';"
    
    Example:
    psql -U qradar -c "update content_package set content_status = 6 where id='601';"
  5. Rerun the psql command. No output must appear.
    psql -U qradar -c "select hub_id,content_status,id from content_package where content_status not in (3,6,9);"
     hub_id | content_status | id
    --------+----------------+----
    (0 rows)
    
  6. Clear the browser cache.
  7. Log in to the QRadar Console GUI as the administrator user.
  8. Install the required application or content package. See Installing extensions by using Extensions Management for more details.
    1. Click the Admin tab.
    2. Click the Extensions Management menu.
    3. In the Extensions Management menu, click Add.
    4. Browse the application or content pack package.
    5. Select the "Install immediately" box.
    6. Click Add.
Result
The required application or content pack finishes the installation or removal successfully. If the administrator continues to experience issues, contact QRadar Support for assistance.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSBQAC","label":"IBM Security QRadar SIEM"},"ARM Category":[{"code":"a8m0z000000cwt3AAA","label":"QRadar Apps"}],"ARM Case Number":"","Platform":[{"code":"PF016","label":"Linux"}],"Version":"7.4.0;and future releases"}]

Document Information

Modified date:
02 May 2022

UID

ibm16574849