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IBM Maximo Application Suite - Login is slow and sometime it fails in IBM Manage application

Troubleshooting


Problem

Login is slow and sometime it fails in IBM Manage application

Symptom

Application takes a few minutes to load

Cause

The problem appears when there are many records in the login tracking application. (order of millions)

Resolving The Problem

The problem appears when there are many records in the login tracking application. (order of millions)
1) Check how many records are in the logintracking table 
Query to use:
select count(*) from maximo.logintracking;
If result is in order of millions proceed to 2)
 
2) Update the database statistics on maximo.logintracking table. If the statistics are not up to date, it has significant impact on the performance, especially to confirm the statistics on logintracking table. For example, you can run the following on DB2 server to make the statistics on logintracking table up to date:
db2 connect to (replace the correct DB name)
db2 "REORG TABLE MAXIMO.LOGINTRACKING ALLOW READ ACCESS"
db2 "RUNSTATS ON TABLE MAXIMO.LOGINTRACKING with distribution AND DETAILED INDEXES ALL ALLOW WRITE ACCESS"
If issue still present, you can try to truncate the table:
IMPORTANT Notes: 
            1) Back-up the logintracking table before running the truncate query.
            2) As a second option, if you do not want to proceed with the truncate query you can use the DELETE query to delete only a specific number of rows from the table based on your selective criteria. 
Query:
truncate table maximo.logintracking immediate;

Note: Same procedure can be applied for Oracle an Microsoft SQL databases.

If issue persists, open a case with support team.

Document Location

Worldwide

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Document Information

Modified date:
16 June 2022

UID

ibm16569493