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Internal error occurred during Manage application activation in IBM Maximo Application Suite

Troubleshooting


Problem

After clicking the Activate button for the Manage application, you receive an AIUCO1999E error:
AIUCO1999E: Internal Server Error: 500
Reason: Internal Server Error

Cause

The problem appears between multiple Manage application activation retries. An invalid webhook resource is left behind and needs to be removed.

Diagnosing The Problem

Look at the error message traceback to find the failing webhook resource:
HTTP response headers: HTTPHeaderDict({'Audit-Id': '1332c9b0-9a62-43f3-8138-49b96c677a5d', 'Cache-Control': 'no-cache, private', 'Content-Type': 'application/json', 'X-Kubernetes-Pf-Flowschema-Uid': 'cfa045f9-b265-44ae-b0db-9824f6b19587', 'X-Kubernetes-Pf-Prioritylevel-Uid': '49992582-3bb2-4ab8-a071-113329ebce24', 'Date': 'Fri, 28 Jan 2022 14:20:37 GMT', 'Content-Length': '625'})
HTTP response body: b'
{"kind":"Status",
"apiVersion":"v1",
"metadata":{},
"status":"Failure",
"message":"Internal error occurred: failed calling webhook \\"ibm-mas-manage-operator-service.mas-xxxxx-manage.svc\\": Post \\"https://ibm-mas-manage-operator-service.mas-xxxxx-manage.svc:443/validate?timeout=10s\\": x509: certificate signed by unknown authority",
"reason":"InternalError","details":{"causes":[{"message":"failed calling webhook \\"ibm-mas-manage-operator-service.mas-xxxxx-manage.svc\\": Post \\"https://ibm-mas-manage-operator-service.mas-xxxxxx-manage.svc:443/validate?timeout=10s\\": 
x509: certificate signed by unknown authority"}]},
"code":500}\n'

Original traceback: 
  File "/usr/local/lib/python3.9/site-packages/openshift/dynamic/client.py", line 42, in inner
    resp = func(self, *args, **kwargs)
  File "/usr/local/lib/python3.9/site-packages/openshift/dynamic/client.py", line 235, in request
    return self.client.call_api(
  File "/usr/local/lib/python3.9/site-packages/kubernetes/client/api_client.py", line 340, in call_api
    return self.__call_api(resource_path, method,
  File "/usr/local/lib/python3.9/site-packages/kubernetes/client/api_client.py", line 172, in __call_api
    response_data = self.request(
  File "/usr/local/lib/python3.9/site-packages/kubernetes/client/api_client.py", line 382, in request
    return self.rest_client.POST(url,
  File "/usr/local/lib/python3.9/site-packages/kubernetes/client/rest.py", line 272, in POST
    return self.request("POST", url,
  File "/usr/local/lib/python3.9/site-packages/kubernetes/client/rest.py", line 231, in request
    raise ApiException(http_resp=r)
The reason of the failure is: x509: certificate signed by unknown authority

Resolving The Problem

You need to remove the invalid webhook in order to fix the issue.
Steps to remove the webhook:
   1) Find the manage webhook in the mas-<masid>-manage namespace
       
oc get validatingwebhookconfiguration -n mas-<masid>-manage
NAME                             WEBHOOKS   AGE
cert-manager-webhook             1          12d
ibm-mas-manage-webhook-masxxxx   1          7h5m
multus.openshift.io              1          12d
prometheusrules.openshift.io     1          12d
vmanage.ibm.com-8lxfb            1          5m35s
   2) In this example, ibm-mas-manage-webhook-masxxxx is the culprit
   3) Remove ibm-mas-manage-webhook-masxxxx
oc delete validatingwebhookconfiguration ibm-mas-manage-webhook-<instance_id> -n mas-<masid>-manage
   4) Go back in IBM Maximo Application Suite UI and Activate Manage application. The error is not received anymore.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSRHPA","label":"IBM Maximo Application Suite"},"ARM Category":[{"code":"a8m3p000000hAeaAAE","label":"Maximo Application Suite-\u003EMAS Applications-\u003EManage"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
10 November 2023

UID

ibm16567491