IBM Support

Disabling Widgets Causes Applications To Crash On Samsung Knox Devices

Troubleshooting


Problem

Disabling widgets in Android policy causes applications to appear to crash.

Symptom

Applications attempt to load but are terminated by the system.

Cause

Disabling widgets in Android Policy.

Environment

Impacts both Device Admin and Android Enterprise enrollments.

Diagnosing The Problem

Applications such as Google Chrome, Google Maps and others attempt to start but get terminated by the system before successfully starting.

Resolving The Problem

Enabling the Allow Widgets option in Android policy resolves this issue.

Android Enterprise enrollments navigate to the Android policy and to Android Enterprise > Security > Allow Widgets > Enable
Save and publish the policy and ensure the device receives the new payload.
Device Admin enrollments navigate to the Android policy and to Device Settings > Security > Allow Widgets > Enable
Save and publish the policy and ensure the device receives the new payload.
allow widgets policy setting

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSYSXX","label":"IBM MaaS360"},"ARM Category":[{"code":"a8m0z000000GnQJAA0","label":"TROUBLESHOOTING"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
28 March 2022

UID

ibm16566915