IBM Support

"Select datasource" window takes minutes to appear after authentication in IBM Planning Analytics for Microsoft Excel (PAfE) 2.0.68

Troubleshooting


Problem

A user opens a worksheet in PAfE, clicks connect, chooses a connection to their environment. After authentication, a window is presented with active Planning Analytics data sources requiring the user to select one. With a particular workbook, this window takes upwards of 4 minutes to appear.

Symptom

Long wait time between authentication and data source prompt window

Cause

A code change in PAfE 2.0.68 flipped the default behavior of the "r68_DisableAltStrategyFormulaGatheringP1" flag from disabled to enabled. 
A cache is created when a user connects to a data source which identifies the cells in a used range. When this flag is enabled (set to false), PAfE adds all the cells in the range to this cache with no checks. When this flag is disabled (set to true), PAfE first identifies which cells are formulas then adds just those to the cache. 
On a worksheet that contains a large range of used cells, a large cache is created in PAfE 2.0.68. This may cause runtime performance as the engine has to search through a huge range each time it uses or adds to the cache.

Environment

IBM Planning Analytics for Microsoft Excel 2.0.68

Diagnosing The Problem

  1. Open the workbook in Microsoft Excel
  2. Click any cell and tap ctrl-end. This brings focus to the last formatted cell on a worksheet
For this workbook, on the first worksheet, a ctrl-end brings focus to row CF, column 1048576

Resolving The Problem

There are two ways to resolve this issue:
  1. Set r68_DisableAltStrategyFormulaGatheringP1= true in the tm1features.json file and restart PAfE
  2. For this worksheet, remove formatting and delete all superfluous rows

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSD29G","label":"IBM Planning Analytics"},"ARM Category":[{"code":"a8m50000000KzJ4AAK","label":"Planning Analytics-\u003EPlanning Analytics For Microsoft Excel"}],"ARM Case Number":"TS008440377","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
25 March 2022

UID

ibm16566109