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Why some users run into the following error message when using PA Workspace workbook: "Sorry, Invalid cell update. Your view session has expired. Please refresh your view and try your action again."

Question & Answer


Question

Why some users run into the following error message when using PA Workspace workbook:
"Sorry, Invalid cell update. Your view session has expired. Please refresh your view and try your action again."

Cause

The issue seems to be related to adding a new member/element to the dimension by a second user while the first user is working with the report using/accessing the same dimension.

Answer

The behavior is as designed.

Whenever a dimension is changed that is, adding a new element to a dimension or deleting an element, triggers a metadata change. A metadata change results in invalidation of related result set that the first user is accessing i.e. a cube view. The reason for this is that each data cell has an index associated with it, adding an element to the dimension changes that index so the old index is not valid anymore or doesn't exist which invalidates the result/data set (i.e view).

Refreshing the view creates a new index that's why it will work after a refresh.

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Document Information

Modified date:
17 March 2022

UID

ibm16563213