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Known issues with IBM Spectrum Protect Operations Center Version 8.1.14

Question & Answer


Question

What are the known issues with IBM Spectrum Protect™ Operations Center Version 8.1.14?

Answer

The following issues have been identified in version 8.1.14 of the Operations Center:

Log-in and general issues

Replication

Servers

Storage Rules

You are locked out of the hub server after fewer invalid login attempts than expected

Symptom

Your administrator ID is configured for multifactor authentication. You accidentally provide invalid credentials when you attempt to log in to the Operations Center, and your administrator ID on the hub server is locked. However, the number of invalid login attempts you made was less than the limit set by the SET INVALIDPWLIMIT command. You were incorrectly locked out of the hub server after too few attempts.

Cause

When you log in to the Operations Center, each invalid login attempt is incorrectly incrementing your Invalid Sign-on Count by 2 instead of by 1. As a result, you reached the limit set by the SET INVALIDPWLIMIT command after fewer actual attempts.

Solution

Have another administrator unlock your administrator ID by using the UNLOCK ADMIN command. Be aware the number of unsuccessful login attempts by using the Operations Center is only half the limit that is set by the SET INVALIDPWLIMIT command. If appropriate for your organization's security guidelines, consider using the SET INVALIDPWLIMIT command to increase the number of unsuccessful login attempts for the version 8.1.14 hub server.

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Replication storage rule fails with error ANR3187E

Symptom

You created a replication storage rule. The replication storage rule's Data to replicate property is set to Specify by subrule, which means the no data is replicated unless specified by a subrule. Because no data is replicated by default, you defined subrules that identify the clients whose file spaces are to be replicated. The storage rule fails and the activity log contains the following informational and error messages:


ANR3185I Replicating node proxy_node_name as a proxy agent for replicated node node_name

ANR3187E Replication of associated replication node associated
replication node_name failed - the node is not configured for replication

Cause

A client has a proxy agent. A proxy agent is another client that acts on behalf of the client. Although the client might be enabled for replication, its proxy agent is not enabled for replication.

Solution

From the ANR3187E error message, identify the name of the client that is the proxy agent. To enable replication for the proxy agent, from the Clients page, select the client and click More > Set Replication.

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A replication storage rule is not replicating certain clients

Symptom

You created a replication storage rule. After the replication storage rule runs, you open the Clients page or the Client Replication page and notice that no data was replicated for one or more of the clients. The replication storage rule's Data to replicate property is either set to All data, which implicitly includes the clients, or is set to Specify by subrule and you have explicitly included the clients by using subrules.

The activity log contains the following warning message:

ANR1934W REPLICATE NODE: Node node name is disabled.

Cause

The clients are not be enabled for replication. Clients that are not enabled for replication are not replicated when the storage rule runs.

Solution

If a client is not being replicated, determine its replication state. You can determine its replication state from the Clients tab of the storage rule's details notebook. To open the details notebook, from the Storage Rules page, select the replication storage rule and click Details. On the Clients tab of the details notebook, the Replication State column shows which clients are enabled for replication. To enable replication for a client, select the client and click Set Replication.

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You cannot add a spoke server after multifactor authentication is configured for your administrator ID

Symptom

On the hub server, multifactor authentication is required for your administrator ID. Because multifactor authentication is required, you log in to the Operations Center by using a one-time passcode in addition to your password. By using the Add Spoke Server wizard, you are attempting to connect a new spoke server to the Operations Center hub server. On the Identity page of the Add Spoke Server wizard, you enter the connection information for the spoke server and click Next. The following error is displayed:

ANRG0091E : The syntax of the following command is not valid: ${0}

Cause

To connect a spoke server that is running version 8.1.14 or later, your administrator ID must be configured on the hub and spoke server with the same password and the same shared secret for generating one-time passcodes. Although multifactor authentication is required for your administrator ID on the spoke server, it is in TRANSITIONAL mode. The TRANSITIONAL mode indicates that your administrator ID on the spoke server is not configured with the same shared secret. For this reason, the Add Spoke Server wizard cannot connect to the spoke server to the Operations Center hub server.

Solution

Make sure that your administrator ID on the hub server and on the spoke server is configured with the same shared secret. To update the shared secret, use the UPDATE ADMIN command. On the UPDATE ADMIN command, specify the correct shared secret on the SHAREDSECRET parameter.

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An object agent that is defined on a server is not shown in the Operations Center

Symptom

You defined an object agent on the server by using the DEFINE SERVER command, or you modified an object agent by using the UPDATE SERVER command. The command completes without errors, and you can verify that the object agent was defined by using the QUERY SERVER command. However, the object agent is not shown in the Operations Center. On the Object Agent page for the server, a message is displayed that says that an object agent must be configured before you can register an object client. If you try to register a client by using the Add Client wizard, you also get a message that says that no object agent is configured. If you try to define an object agent by using the Operations Center, the following error message is written to the activity log:

ANR4610E Command: An object agent server is already defined.

Cause

When you define an object agent by using the Operations Center, the Operations Center defines an endpoint to which object clients can send S3 requests. This endpoint is formed by using the IP address of the server and a port number. In the Operations Center, you can configure only the port number. The IP address is automatically determined to be the same as the server's IP address. When the object agent was created or modified by using the DEFINE SERVER or UPDATE SERVER command, a high-level address was specified that does not match the IP address of the server. For this reason, the Operations Center incorrectly determines that no object client is defined on the server.

Solution

Use the UPDATE SERVER command to update the object agent. By using the HLAddress parameter of the command, specify the IP address of the IBM Spectrum Protect server.

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Storage rule summary pages do not show recent data in the two-week history chart or the Recent History area

Symptom

To view the performance history of a storage rule, you select the storage rule on the Storage Rules page, and click Details. From the storage rule's details notebook, you go to the summary page for the storage rule, for a subrule, or for a source pool. The two-week history chart is empty or is missing the most-recent data. The Recent History area of the page is also missing data.

Cause

The CHECKFORTIERSTATS server option is set to No. In some situations, background processes for identifying eligible file spaces to be copied can degrade the performance of a storage rule. As a workaround to improve performance, the CHECKFORTIERSTATS server option was set to No. A side effect of that workaround is that the Operations Center cannot populate storage-rule summary pages with recent history. The information that is normally collected in the background to populate the two-week history chart and the Recent History area is not collected while the CHECKFORTIERSTATS server option is set to No.

Solution

Use the QUERY OPTION command to display the current setting of the CHECKFORTIERSTATS server option. From the command line, issue the following command:


q opt checkfortierstats

If the CHECKFORTIERSTATS server option is set to No, you can resolve this problem by setting the server option to Yes. If you set the CHECKFORTIERSTATS server option to Yes, the recent history is not immediately restored, but begins to be collected again the next time the storage rule runs. If the server option was previously set to No to resolve a performance problem, understand that setting it to Yes might degrade storage rule performance. You might need to choose between improved performance or displaying the two-week historical data.

To set the CHECKFORTIERSTATS server option, issue the following command:


setopt checkfortierstats yes

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[{"Type":"MASTER","Line of Business":{"code":"LOB26","label":"Storage"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSEQVQ","label":"IBM Spectrum Protect"},"ARM Category":[{"code":"a8m3p000000hAZvAAM","label":"Operations Center"}],"ARM Case Number":"","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"8.1.14"}]

Document Information

Modified date:
11 March 2022

UID

ibm16561661