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Cannot generate report [Cannot connect to datasource. oracle.jdbc.driver.OracleDriver]

Troubleshooting


Problem

Client is configuring IBM Cognos Controller for 'Embedded Report Library'.

Upon testing a standard report, a similar error is displayed on screen:
File does not begin with '%PDF-'.
C:\users\userid\AppData\Roaming\Cognos\CCRRports\crdreport_name_...pdf
image-20220223155113-2

Cause

Incorrect configuration of the 'Embedded Report Library'

Environment

IBM Cognos Controller
Controller database is using Oracle.
 (Note The same situation can occur while using SQL Server of Db2.  However, by default those software are pre-configured and do not require any extras steps.)

Diagnosing The Problem

After, receiving, the generic error image (File does not begin with '%PDF-':
  1. Open the file mentioned on the error by using a text editor software.  The actual error is recorded on that .pdf file
  2. On this scenario, the error recorded on the .pdf file is:  Cannot generate report [Cannot connect to datasource. oracle.jdbc.driver.OracleDriver]

Resolving The Problem

1-Place a copy of your Oracle JDBC driver in the following directories:
  • C:\Program Files\ibm\cognos\ccr_64\fcmweb\wlp\usr\shared\resources\JDBCDriver
  • C:\Program Files\ibm\cognos\ccr_64\fcmweb\wlp\usr\servers\fcm.reports\apps\fcm.reports-rest.war\WEB-INF\lib
2-Restart the IBM Cognos Controller Report service
3-Log on to IBM Cognos Controller and run a standard report

Document Location

Worldwide

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Document Information

Modified date:
23 February 2022

UID

ibm16558972