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Connect Direct File Agent is not showing in Control Center

Troubleshooting


Problem

Setting up a new configuration for Connect Direct and File Agent.
Control Center sees the Connect Direct server, but the File Agent does not show up in Control Center.

Symptom

Control Center does not list the File Agent under the CD Server

Cause

On the File Agent they were using a cddef.jcu file and not defining the Connect Direct address and API port in the File Agent configuration (.ser).

Diagnosing The Problem

The Control Center FileAgentService logs show WARN  FileAgentService - Received trap from a File Agent which submits Processes to a server (ip-address;0) we are not monitoring.
The issue here is the port shows as 0 not the actual API port defined in Connect Direct.

Resolving The Problem

Set API host DNS name and API port in the File Agent configuration as a work around.
Apply File Agent 1.4.0.2_iFix025 or later to resolve the issue.

Document Location

Worldwide

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Document Information

Modified date:
20 April 2022

UID

ibm16557476