Troubleshooting
Problem
When logging in to a TM1 Server secured with CAM Authentication in Perspectives, a script error occurs.
Cause
The problem is caused due to modern day browser functionality that is not available in older browsers (older IE browsers), used in the background of Excel. The registry must updated to modify the behaviour of these older browsers.
Resolving The Problem
Update the following registry entries in your environment to include excel.exe:
For 32bit Excel:
Key="HKLM\SOFTWARE\Wow6432Node\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_USE_WINDOWEDSELECTCONTROL"
For 64bit Excel:
For 64bit Excel:
Key="HKLM\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_USE_WINDOWEDSELECTCONTROL"
Steps to Implement:
Steps to Implement:
- Run regedit to open the Registry Editor.
- Navigate to the appropriate key.
- If the keys already exist for excel.exe, modify the settings to the appropriate values.
*If the keys do not exist, then proceed to the next step. - Right-click and create a new DWORD (32 bit) Value.
- Rename the new DWORD to "excel.exe".
- Right-click the new DWORD, click "Modify..." and select Decimal.
- Specify the integer value "0" for FEATURE_USE_WINDOWEDSELECTCONTROL
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSD29G","label":"IBM Planning Analytics"},"ARM Category":[{"code":"a8m0z0000001i7nAAA","label":"TM1 Perspectives"}],"ARM Case Number":"TS008042210","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]
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Document Information
Modified date:
16 February 2022
UID
ibm16557004