IBM Support

Control Center will not start after upgrading from 6.1.2.0 to 6.2.1.0

Troubleshooting


Problem

After upgrading Control Center the Engine is not starting.  Seeing errors in the logs.

Symptom

Control Center will no longer start fails at the same place each time.
None of the Control Center ports are listening.

Cause

CC_SERVER table had multiple entries with a NODE_TYPE_ID equal to 101.
CC_SERVER_GROUP table had an entry for NODE_TYPE_ID 101 whose name was 'All SFTP Servers'
The NODE_TYPE table had no entry for 101.

Diagnosing The Problem

The Engine log shows the following error.
[CCEngine(CCenter)] INFO Controller - Making sure all servers are assigned to an event processor...
[CCEngine(CCenter)] WARN Runtime - Detected possible orphaned reference to deleted object "101" in "com.ibm.cc.model.generated.Server._type".
 [CCEngine(CCenter)] ERROR ControllerMonitor - Exception in ControllerMonitor constructor - null
java.lang.NullPointerException: null
at com.ibm.cc.model.Server.isSystemNode(Server.java:639)

Resolving The Problem

INSERT INTO NODE_TYPE (NODE_TYPE,NODE_TYPE_DESCR,NODE_TYPE_CODE) VALUES (101,'SFTP','sftp')

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSJC3O","label":"IBM Sterling Control Center Monitor"},"ARM Category":[{"code":"a8m0z000000cwVyAAI","label":"ENGINE"}],"ARM Case Number":"TS008385286","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"6.2.0;6.2.1"}]

Document Information

Modified date:
10 February 2022

UID

ibm16555160