IBM Support

"Installation directory already exists" error when installing over an existing Cognos installation

Troubleshooting


Problem

When installing over an existing Cognos installation, an error message saying that "the install location already exists" is returned.
image-20220207131403-1

Cause

The full path to the Cognos installation is not specified. For example, the path "C:\Program Files\ibm\cognos" is specified, but the full installation path is "C:\Program Files\ibm\cognos\analytics".

Diagnosing The Problem

Check whether the full path to the Cognos installation is specified.

Resolving The Problem

To resolve the issue, specify the full path to the Cognos installation. For example, "C:\Program Files\ibm\cognos\analytics".image-20220207132513-1

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m50000000Cl6sAAC","label":"Installation\/Configuration-\u003ECognos Configuration"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
07 February 2022

UID

ibm16554206