Troubleshooting
Problem
Planning Analytics Workspace is running on Linux.
The "./scripts/paw.sh ps" command shows that all containers are "Up", except for "bss-init" and "couchdb-init", which is the expected behavior.
From a remote machine, no web browser is able to access the login page. The page is not found.
From Edge:
Hmmm… can't reach this page
<servername> took too long to respond
ERR_CONNECTION_TIMED_OUT
<servername> took too long to respond
ERR_CONNECTION_TIMED_OUT
From Chrome:
This site can't be reached
<servername> took too long to respond
ERR_CONNECTION_TIMED_OUT
ERR_CONNECTION_TIMED_OUT
From Firefox:
Hmm. We’re having trouble finding that site.
We can’t connect to the server at <servername>
We can’t connect to the server at <servername>
From a remote machine, it is possible to ping the Linux.
However, the "telnet <servername> <PAWport>" command is not responding.
Nevertheless, the "telnet <servername> <PAWport>" command is responding from the Linux itself.
Also, the following command is responding with HTTP 200 (meaning this is OK: pa-gateway is responding):
curl -Is http://<servername>:<PAWport> | head -n 1
If we try to use a web browser from inside the Linux, through some X-windows-like tool, Workspace can be reached but is responding with another error message:
An unexpected error has occurred.
Cause
Linux IP forwarding was set to 0, either manually or through some batch.
Resolving The Problem
Run this command on Linux in order to display the current value of IP forwarding parameter:
$ cat /proc/sys/net/ipv4/ip_forward
0
Set this parameter to 1:
$ sudo sysctl -w net.ipv4.ip_forward=1
net.ipv4.ip_forward = 1
No need to reboot or restart anything.
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSCTEW","label":"IBM Planning Analytics Local"},"ARM Category":[{"code":"a8m50000000KzIzAAK","label":"Planning Analytics Workspace"},{"code":"a8m0z000000blfjAAA","label":"Troubleshooting"}],"ARM Case Number":"","Platform":[{"code":"PF016","label":"Linux"}],"Version":"All Versions"}]
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Document Information
Modified date:
03 February 2022
UID
ibm16553616