Troubleshooting
Problem
IBM Security® Guardium® Appliance was successfully upgraded to Version 11 and GPU 300.
Prerequisite to install the next bundles is the health check patch 9997 and this patch installation fails.
Symptom
Health check patch installation fails with the message "ERROR: Patch Installation Failed - Recovery from pre patch backup Succeeded".
health_check.YYYYMMDDhhmmss.log is generated in the current directory of the generated diagnostics from "support must_gather patch_install_issues" cli command.
The actual health check log file content is:
There is NO issue with DB size. ERROR: root partition has less than 1.5G of free space. Obsolete column DATAMART.AGG_ANALYTIC_INPUT.AVG_EXECUTION_TIME was not found. Hardware is not a recognized type. Skipping version check No need to rebuild rolemap ---------------------------------- MYSQL TABLE VALIDATION STARTED.... List of crashed tables: Database TURBINE: No issue found. Database GDMS: No issue found. Database CUSTOM: No issue found. Database DATAMART: No issue found. Database DIST_INT: No issue found. MYSQL TABLE VALIDATION ENDED. ---------------------------------- No crashed tables found. Please send this log file to support team. |
Cause
Before installation of any patch, the release notes must be studied. The health check patch 9997 release notes are indicative of expected messages in log files for the known cases.
The message "ERROR: root partition has less than 1.5G of free space." is expected if the (/) root partition does not have enough space.
If the appliance's (/) root partition is 10 Gb in size due to its history of being built from an ISO image of old product version based on the old product architecture.
Environment
This content applies to any V11.x Guardium appliance with GPU 300.
Diagnosing The Problem
"support must_gather patch_install_issues" needs to be executed to generate a diagnostics file.
health_check.YYYYMMDDhhmmss.log is generated in the current directory of the generated diagnostics
Resolving The Problem
To support newer features, the product architecture was modified to have a higher (/) root partition size of 25 Gb.
The quickest and only way in this situation is:
1. Take a full system backup
2. Create a new appliance by using the latest ISO image from the Passport Advantage portal.
3. Restore the system backup on the newly created appliance
4. Proceed with the planned patching effort
Related Information
Document Location
Worldwide
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Product Synonym
IBM Security Guardium
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Document Information
Modified date:
18 February 2022
UID
ibm16552356