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OVA upgrade fails for v10.0.1.5 with no available PVs(persistent volumes)

Troubleshooting


Problem

One, or more, of the pods in the VMWare API Connect deployment are stuck in Pending state

Symptom

The upgrade fails with and "describe" of the pod shows this error:
Warning  FailedScheduling  45m   default-scheduler  0/1 nodes are available: 1 node(s) didn't find available persistent volumes to bind.
This error means the system might have run out of PVs, most likely due to the main subsystem CR "siteName" having changed in the past.

Cause

There are no available PVs to bound; the upgrade cannot continue.

Environment

OVA upgrades to v10.0.1.5

Diagnosing The Problem

To see if this is the problem, run:

For a portal subsystem:

kubectl get --no-headers pvc | grep -v -- -$(kubectl get ptl -o jsonpath="{.items[0].spec.siteName}")- | awk '{print $1}'

For a management subsystem:

kubectl get --no-headers pvc | grep -v -- -$(kubectl get mgmt -o jsonpath="{.items[0].spec.siteName}")- | awk '{print $1}'

Resolving The Problem

If anything is printed to the console then run the following commands to delete the old PVCs which will then free up the PVs for use by the Pending pods:

root@apimdev0075:~# SITENAME=$(kubectl get ptl -o jsonpath="{.items[0].spec.siteName}")
root@apimdev0075:~# echo $SITENAME
mycurrentsite

Then check the output is the siteName of your Portal/Management subsystem, and then run:

root@apimdev0075:~# kubectl get --no-headers pvc | grep -v -- -${SITENAME}- | awk '{print $1}' | xargs kubectl delete pvc

This should delete the old PVCs and then the PVs will become available and your Pending pods should be able to start

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSMNED","label":"IBM API Connect"},"ARM Category":[{"code":"a8m50000000L0rvAAC","label":"API Connect"}],"ARM Case Number":"TS008221088","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"10.0.0"}]

Product Synonym

API Connect

Document Information

Modified date:
01 February 2022

UID

ibm16551446