Troubleshooting
Problem
When trying to upgrade Planning Analytics Workspace, users get the following message and there is no Start.log created in the admintool log directory:
Looks like something went wrong in step "Installing/Updating IBM Planning Analytics Docker images"... Check the log file /data/ipa_workspace_win_2.0.xx/log/admintool/start_xxxx_xx_xx.log... Press Enter to continue...
Cause
This error indicates that there is no space on the drive where the images will be extracted.
-On Windows > the default drive is C:\
*Unless the docker data root was updated to use different drive in C:\ProgramData\docker\config\daemon.json
-On Linux > The default directory is /var/lib/docker
Resolving The Problem
There are two suggested solutions.
1- Perform the following steps:
- Take a backup from old install
- Uninstall the old Planning Analytics workspace version
- Run docker system prune -a to remove old images https://www.ibm.com/support/knowledgecenter/en/SSD29G_2.0.0/com.ibm.swg.ba.cognos.tm1_inst.2.0.0.doc/t_paw_uninstall.html
2- Add extra disk space to the needed drive.
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSD29G","label":"IBM Planning Analytics"},"ARM Category":[{"code":"a8m50000000KzIzAAK","label":"Planning Analytics Workspace"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]
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Document Information
Modified date:
13 January 2022
UID
ibm16540302