IBM Support

Planning Analytics Workspace: Indefinite Loading bar when accessing a TM1 server

Troubleshooting


Problem

Unable to connect to a TM1 server from Planning Analytics Workspace (PAW) for modelling as a loading bar appears indefinitely below the TM1 server.
Planning Analytics Workspace: TM1 Server Loading Bar
A connection could not be established from PAW however the same model was accessible via Architect.

Symptom

In the browser HAR trace, we see an entry:
GET http://<admin_server_name>/prism/harmony/gridservice/api/v1/Servers('<TM1_server>')/Login 
with the following error: 

{"error":{"code":"EXECUTION_ERROR","message":"org.apache.http.conn.ConnectTimeoutException: Connect to <ip_address>:52670 [/<ip_address>] failed: connect timed out"}}

Cause

The issue is due to strict Windows Firewall rules that blocked the HTTPPortNumber, which the TM1 Server uses to listen for incoming HTTP(S) requests.

Resolving The Problem

To resolve the issue, create an inbound firewall rule for the affected TM1 server's HTTPPortNumber.
The affected port number can be found in the models tm1s.cfg file or from the browser HAR trace. 
Example: The blocked port number "52670" is mentioned in the following HAR trace error:
{"error":{"code":"EXECUTION_ERROR","message":"org.apache.http.conn.ConnectTimeoutException: Connect to <ip_address>:52670 [/<ip_address>] failed: connect timed out"}}

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSCTEW","label":"IBM Planning Analytics Local"},"ARM Category":[{"code":"a8m50000000KzIzAAK","label":"Planning Analytics Workspace"}],"ARM Case Number":"TS007912603","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
09 January 2022

UID

ibm16538880