IBM Support

500 Error in IIS Gateway when file system security is in use, and the service account password has changed.

Troubleshooting


Problem

Accessing an IIS Gateway suddenly presents HTTP Error Code 500.19

Symptom

Error Code 500.19
Config Error Can not log on locally to <Webcontent path> as user <Service Account> with virtual directory password

Cause

The password for the service account used by Cognos was changed, resulting in the necessary file system access being denied.

Environment

Cognos Analytics
IIS WebServer
Gateway is configured to use file system security to access the WebContent path.

Diagnosing The Problem

Enable "Detailed Errors" in IIS
  1. Open IIS Manager
  2. Click the "Default Web Site"
  3. Double-click "Error Pages"
  4. Click "Edit Feature Settings"
  5. Select "Detailed Errors"
  6. Click OK until out of the menus

Resolving The Problem

  1. Confirm the <Service Account> user exists as a user on the server and that it is in the administrator group.
  2. Confirm you have the correct password for the <Service Account> user, or, if not, reset it.
  3. In IIS manager, under sites > Default Sites > ibmcognos, click Advanced Settings.
  4. Under physical path credentials, make sure the specific user is <Service Account> user and it is using the correct password. 

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m50000000Cl6dAAC","label":"Installation and Configuration-\u003EWeb Server"}],"ARM Case Number":"TS007527431","Platform":[{"code":"PF033","label":"Windows"}],"Version":"11.0.0;and future releases"}]

Document Information

Modified date:
01 January 2022

UID

ibm16537996