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Using correct password but get 'Connection failed due to invalid credentials' error when testing DSN in IBM Cognos Secure Gateway

Troubleshooting


Problem

Unable to connect to the DB2 datasource from IBM Cognos Secure Gateway (SG)

Symptom

Get the following errors:
1. PAA Secure Gateway admin test of the data source with user name and password returns: "Connection failed due to invalid credentials." The same credential is working outside of PA
2. See the following error in tm1server.log when testing a simple query in a TI process that uses the same ODBC connection name: 'SQL30082N Security processing failed with reason "17" ("UNSUPPORTED FUNCTION"). SQLSTATE=08001'

Cause

The client sent SERVER_ENCRYPT authentication information to a server that does not support password encryption.

Environment

IBM Planning Analytics on Cloud
IBM Cognos Secure Gateway 

Diagnosing The Problem

The authentication type set for the database is 'SERVER' not 'SERVER_ENCRYPT'

Resolving The Problem

Uncatalog and catalog the database with the correct authentication type by using the following DB2 commands:

UNCATALOG SYSTEM ODBC DATA SOURCE 'data source name'

UNCATLOG DATABASE 'database name'

UNCATALOG NODE 'node name'

CATALOG TCPIP NODE 'node name' remote 'hostname' server 'server name'

CATALOG DATABASE 'database name' as 'alias' at node 'node name' authentication SERVER_ENCRYPT

CATALOG SYSTEM ODBC DATA SOURCE 'data source name'

Document Location

Worldwide

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Document Information

Modified date:
21 December 2021

UID

ibm16528430