Troubleshooting
Problem
Unable to connect to the DB2 datasource from IBM Cognos Secure Gateway (SG)
Symptom
Get the following errors:
1. PAA Secure Gateway admin test of the data source with user name and password returns: "Connection failed due to invalid credentials." The same credential is working outside of PA
2. See the following error in tm1server.log when testing a simple query in a TI process that uses the same ODBC connection name: 'SQL30082N Security processing failed with reason "17" ("UNSUPPORTED FUNCTION"). SQLSTATE=08001'
Cause
The client sent SERVER_ENCRYPT authentication information to a server that does not support password encryption.
Environment
IBM Planning Analytics on Cloud
IBM Cognos Secure Gateway
Diagnosing The Problem
The authentication type set for the database is 'SERVER' not 'SERVER_ENCRYPT'
Resolving The Problem
Uncatalog and catalog the database with the correct authentication type by using the following DB2 commands:
UNCATALOG SYSTEM ODBC DATA SOURCE 'data source name'
UNCATLOG DATABASE 'database name'
UNCATALOG NODE 'node name'
CATALOG TCPIP NODE 'node name' remote 'hostname' server 'server name'
CATALOG DATABASE 'database name' as 'alias' at node 'node name' authentication SERVER_ENCRYPT
CATALOG SYSTEM ODBC DATA SOURCE 'data source name'
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSD29G","label":"IBM Planning Analytics"},"ARM Category":[{"code":"a8m0z000000GmwdAAC","label":"1 - Migrated Categories-\u003EBA - Planning Analytics Cloud-\u003ETroubleshooting-\u003ESecure Gateway"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]
Was this topic helpful?
Document Information
Modified date:
21 December 2021
UID
ibm16528430