IBM Support

Cognos Administration Console not Loading Correctly with SSO Enabled

Troubleshooting


Problem

Accessing Cognos using SSO, the Administration Console does not load correctly and is missing icons and styling.

Symptom

Administration Console is missing icons and styling as shown below:
Image showing the Administration Console displaying incorrectly with missing CSS, images and icons

Cause

HTTP_X_WEBCONTENTROOT variable under the Header re-write rule was not set correctly in IIS.

Diagnosing The Problem

  • Navigate to the Cognos Administration Console in your browser and observe the page loaded improperly
  • Open up the browser Developer Tools by hitting F12
  • Navigate to the Network tab, start recording then refresh the webpage
  • Observe the 404 responses for the skins, icons, etc that the page tried to load
  • Double-click on one of the responses to open the details, the URL being requested is incorrect

Resolving The Problem

Method 1:
- Access IIS and the Cognos application within (i.e ibmcognos).
- Locate and select the "URL Rewrite" within the "bi" virtual directory.
- Select and edit the "Headers" rule.
- Locate "HTTP_X_WEBCONTENTROOT" under Server Variables and ensure the following:
Name = HTTP_X_WEBCONTENTROOT
Value = /ibmcognos (or the name set for the alias)
Replace = True
If recreating this variable does not work, Method 2 below will ensure a fresh configuration.
Method 2:
- Re-run the IIS script. 
 

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m50000000Cl3zAAC","label":"Administration"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
16 December 2021

UID

ibm16526722