Troubleshooting
Problem
Starting an IBM Cognos Analytics server fails CFG-ERR-0106 shown in Cognos Configuration.
Symptom
Messages in the Details popup window of Cognos Configuration show that some services starts successfully and then suddenly the process of starting services starts from the beginning.
After a number of iterations, the error message CFG-ERR-0106 is shown.
In Windows Task Manager, a java.exe process apears, starts consuming significant part of CPU as expected and then suddenly disappears. No dump files are generated. A new java.exe process is started as expected but it also disappears, and so on.
Cause
Trend Micro Internet Security is installed on the server. It scans files and folders in the IBM Cognos Analytics installation.
Diagnosing The Problem
In Microsoft Process Monitor trace, the process coreServiceShell.exe constantly reads files in the Cognos installation folder as the java.exe process updates them.
Resolving The Problem
Uninstall Trend Micro Internet Security or exclude the installation folder of Cognos Analytics from scanning
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m50000000Cl3yAAC","label":"Installation and Configuration"}],"ARM Case Number":"TS007753710","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions"}]
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Document Information
Modified date:
13 December 2021
UID
ibm16525886