IBM Support

Planning Analytics Administration (Workspace) Fails to Communicate With Admin Agent

Troubleshooting


Problem

Upon opening of Planning Analytics Administration (Workspace), the status of the agent is Unavailable.  The agent is also unable to provide TM1 Server metrics.

Symptom

Review of the monitor service logs from the Planning Analytics Workspace logs folder, indicates that there is an authentication error between Workspace and the Agent.

Cause

An Agent API Key might have been added to either Workspace or the Agent.

Resolving The Problem

Per: https://www.ibm.com/support/pages/whats-coming-next-ibm-planning-analytics-workspace-2060
-Check to see whether the bootstrap.properties file for the PA Agent contains: AGENT_API_KEY_ENCODED=
   *Setting can also be AGENT_API_KEY, which is the parameter name before a restart occurs (restart is required)
-If the Agent uses an API KEY, the Workspace paw.env file must contain the equivilent key: export AdminAgentAPIKey=<KEY_VALUE>

Document Location

Worldwide

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Document Information

Modified date:
07 December 2021

UID

ibm16524238