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Planning Analytics Administration Agent version number is not updated in the Workspace interface

Troubleshooting


Problem

Although IBM Planning Analytics Administration Agent was updated, the old version number is still displayed in Planning Analytics Workspace administration interface.

Symptom

The issue is triggered in the get_win_registry_details method that is defined in the status.py script (from "\tm1_64\paa_agent\wlp\usr\servers\kate-agent\kateagent\scripts" folder)

This issue is caused by the Python's strip() function that removes leading and trailing spaces.

The error happens while trying to get the configuration path ("ConfigPath") of the service.

Error message in "\tm1_64\paa_agent\wlp\usr\servers\kate-agent\logs\console.log":

000000a5 SystemErr                          R ERROR:status.py:---- pa prod server ----Error while getting windows registry details: ERROR: The system was unable to find the specified registry key or value.

Due to this error, the ServersInfo.json file is not updated to reflect the actual version number of the Administration Agent.

Cause

One of the running TM1 Server services does contain a leading space or trailing space in its display name.

Resolving The Problem

Having a leading space or trailing space in the display name of a Windows service is most probably a typographical error.
In order to resolve the issue, the service display name has to be changed.
This modification can be done with a single command:
sc config <Service Name> DisplayName= "New Display Name"
This command has to be executed in a cmd.exe window, run as administrator.
The "Service Name" parameter is not the old display name: it is the "Service name" that appears in the General tab of the service properties, for example:
image 12442
Aftert this change, perform these tasks:
-Restart the TM1 Server service
-Stop "IBM Planning Analytics Administration Agent" service
-Delete these files:
     \tm1_64\paa_agent\paaAgentCache\serversInfo.json
     \tm1_64\paa_agent\paaAgentCache\KATE_TEMP\serversInfo.json
-Start "IBM Planning Analytics Administration Agent" service
-Reconnect to Workspace and go to Administration in order to trigger the rebuild of serversInfo.json

Document Location

Worldwide

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Document Information

Modified date:
02 December 2021

UID

ibm16522846