Troubleshooting
Problem
The following containers are in "Exit" or "Restarting" state shortly after restarting Planning Analytics Workspace:
pa-content
async-service
neo-idviz
wa-proxy
Symptom
The same error appears in all these log files:
<paw>/log/pa-content/app*.log
<paw>/log/async-service/server*.log
<paw>/log/wa-proxy/WAProxy*.log
Error:
uncaughtException: ENOENT: no such file or directory, open 'C:\share\db_secret.key'
Cause
Missing files related to SSL/TLS configuration (even if using no custom SSL)
Resolving The Problem
Ensure that these four files are present in <paw>/config/ssl folder:
cookie_secret.key
credential_store.key
db_secret.key
pa-workspace.pem
credential_store.key
db_secret.key
pa-workspace.pem
If not, then retrieve the missing files from the Planning Analytics Workspace installation kit (downloadable from IBM Fix Central)
Once there is no missing files anymore; stop, regenerate and restart all containers by using these commands in Powershell:
cd <paw>
./scripts/paw.ps1 stop
./scripts/paw.ps1
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSD29G","label":"IBM Planning Analytics"},"ARM Category":[{"code":"a8m50000000KzIzAAK","label":"Planning Analytics Workspace"},{"code":"a8m50000000KzK7AAK","label":"Security-\u003ESSL"},{"code":"a8m0z000000blfjAAA","label":"Troubleshooting"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]
Was this topic helpful?
Document Information
Modified date:
16 November 2021
UID
ibm16516704