IBM Support

Snowflake JDBC driver internal error: Timeout waiting for the download while running reports.

Troubleshooting


Problem

Running reports against a Snowflake data source return a Snowflake JDBC driver internal error. 

Symptom

Running the reports returns the following error. It may be intermittent and the "Total chunks" value may differ:
net.snowflake.client.jdbc.SnowflakeSQLLoggedException: JDBC driver internal error: Timeout waiting for the download of #chunk0(Total chunks: 1) retry=0.
Reports can run slow.

Cause

An incompatible version of the Snowflake JDBC driver is in use.

Diagnosing The Problem

Check for the error message in the logs. Check the version of the driver in the <Cognos install>/drivers directory.

Resolving The Problem

Make sure the version of the JDBC driver placed in the <Cognos install>/drivers directory meets the version requirements on the IBM Cognos Analytics Supported Software Environments page. Also, check the Vendor-supported client driver versions that were tested for each Cognos Analytics 11.1.x release page to see specific versions that IBM Cognos has tested in-house and test with one of the versions listed on the page for the environment's Fix Pack level.

Document Location

Worldwide

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Document Information

Modified date:
07 January 2022

UID

ibm16515142