IBM Support

Rhapsody client accessing Remote Artifacts Package results in error

Troubleshooting


Problem

When you access Remote Artifacts Package from a Rhapsody client, the following error is displayed:

Consumer key <consumer_key> needs to be approved on remote server TRS 2.0 for DOORS Next Process Resources
(https://<elm_server_url>:<port>/rm/rootservices).

Symptom

1. The following error is displayed
image 12090
2. When you access Remote Artifacts Package from a local Rhapsody client on IBM Engineering Lifecycle Management(ELM) server where IBM Engineering Requirements Management DOORS Next(RM) is installed, there is no problem.
3. This issue happens only to Rhapsody client machines that are NOT on the ELM server where RM is installed.

Cause

The system time on the Rhapsody client machine and the system time on the ELM server machine are NOT in sync.

Resolving The Problem

Make sure that the system time on the Rhapsody client machine is in sync with the system time on the ELM server.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSB2MU","label":"IBM Engineering Systems Design Rhapsody"},"ARM Category":[{"code":"a8m50000000Cjc8AAC","label":"Rhapsody->Model Manager->Rhapsody Client"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
27 May 2022

UID

ibm16514735