IBM Support

From some client machines: either the Task Pane is not visible, or user gets The remote server returned an error: (404) Not Found

Troubleshooting


Problem

From some client machines: either the Task Pane is not visible, or user gets this error:
IBM Framework for Microsoft Office
The remote server returned an error: (404) Not Found
Cognos.Office.Tm1.Connections.Tm1WebException: The remote server returned an error: (404) Not Found ---> System.Net.WebException: The remote server returned an error: (404) Not Found
  at System.Net.HttpWebRequest.GetResponse()
  at Cognos.Office.Tm1.Connections.Tm1Request.GetResponse()
...

Cause

Wrong version of Planning Analytics for Excel, or bad Connection URL.

Resolving The Problem

- On the client machine, in Excel, from "IBM Planning Analytics" tab, go to Help --> About and take note of the exact version.
Then, on the Planning Analytics Workspace server, open <Workspace_install>/config/version .ps1 or version.env, and compare that version to the client version: the difference must not be too large. Ideally, if the Workspace version is N, then it is best to have the client add-in version between N-2 and N+1.
- On the client machine, open CommManagerSettings.xml that resides in C:\Users\<UserName>\AppData\Local\Cognos\Office Connection
Search for your connection URL and verify that dataSource="TM1OData" and not "TM1Rest".  If datasource is set to "TM1Rest", that means it tries to use "pmhub", which is not supported anymore (since Planning Analytics 2.0.9.3 and Planning Analytics for Excel 2.0.52). All connection URLs now have to use "TM1OData" connection type, which is officially available since Planning Analytics for Excel 2.0.42.
- On the client machine, open CommManagerSettings.xml that resides in C:\Users\<UserName>\AppData\Local\Cognos\Office Connection
Search for your connection URL and copy the "gateway" URL. Paste this URL in a web browser and verify you are able to connect to Planning Analytics Workspace.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSD29G","label":"IBM Planning Analytics"},"ARM Category":[{"code":"a8m50000000KzJ4AAK","label":"Planning Analytics for Microsoft Excel"},{"code":"a8m0z000000blfjAAA","label":"Troubleshooting"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
26 October 2021

UID

ibm16508804