IBM Support

Order Hub throws 'User is not authorized to access OMS' message

Troubleshooting


Problem

On logging in to the Order Hub application, the landing page displays the message "User is not authorized to access OMS". Due to this behavior, users are not able to access Order Hub screens.

Cause

This error can come up due to many reasons but the most common ones are listed here -
  • User is created in IBM Order Management System(OMS) with the contact email id different than the user's IBMid.
  • Multiple users exist in OMS with the contact email id same as user's IBMid.
  • Out of the box value for yfs.jwt.verify.keyloader is changed in System Administration Console(SMA) application.

Resolving The Problem

Here is the resolution for different causes of this error -
  • User is created in IBM Order Management System(OMS) with the contact email id different than the user's IBMid.
    • Ensure that the user is created in OMS system per the following link.
  • Multiple users exist in OMS with the contact email id same as user's IBMid.
    • Delete the duplicate users created in OMS with the contact email id same as user's IBMid.
    • Query select loginid,username,CONTACT_EMAIL_LOW from yfs_user can be run to identify such records.
  • Out of the box value for yfs.jwt.verify.keyloader is changed in System Administration Console(SMA) application.
    • Order Hub looks at the default value of yfs.jwt.verify.keyloader=httpsjwks set at the root/global level in SMA application. Hence, this value need not be modified.
    • The issuer-specific configuration can be configured in customer_overrides.properties file separately if needed to override the SMA global configuration - yfs.yfs.jwt.<issuer name>.verify.keyloader=properties
    • Documentation Reference

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS6PEW","label":"IBM Sterling Order Management"},"ARM Category":[{"code":"a8m0z000000cy05AAA","label":"OrderHub"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"SaaS"}]

Document Information

Modified date:
27 June 2022

UID

ibm16506701