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Unable to delete PVC when retrying APIC upgrade from 2018 to v10.

Question & Answer


Question

How to delete a PVC that remains in "Terminating" state after a failed attempt of apic upgrade from 2018 to v10?

Cause

Even after a force deletion of the pvc, it remains in "Terminating" state:

"kubectl delete pvc pv-claim-apiconnect-v10-upgrade --force --grace-period=0 -n default"

Persistentvolumeclaim "pv-claim-apiconnect-v10-upgrade" force deleted

PVC is not deleting due to the finalizers, which are blocking the deletion.  You can read more about it here:

https://kubernetes.io/docs/tasks/access-kubernetes-api/custom-resources/custom-resource-definitions/#finalizers

Answer

To resolve this issue, you can update the pvc and clear the finalizers:
kubectl patch pvc {PVC_NAME} -p '{"metadata":{"finalizers":null}}'

This command unsets the finalizers allowing the pvc to be deleted.

After deleting the pvc, continue to run the cleanup script and restart the upgrade process:

[{"Type":"MASTER","Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSMNED","label":"IBM API Connect"},"ARM Category":[{"code":"a8m50000000CeCAAA0","label":"API Connect->Management and Monitoring (MM)->Upgrade\/Downgrade"}],"ARM Case Number":"TS006541086","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"10.0.0;2018.4.1.0"}]

Document Information

Modified date:
06 October 2021

UID

ibm16496819