Troubleshooting
Problem
Log in Failed: SystemServerClientNotFound error is received attempting to logon to a CAM authenticated TM1 Server with Architect and Perspective.
Symptom
The Cognos Analytics Dispatcher used by TM1 Server for authentication is SSL secured and the corresponding certificates have been correctly imported within the TM1 Server keystore as per the following documentation.
https://www.ibm.com/support/pages/how-configure-planning-analytics-connect-ssl-secured-cognos-dispatcher
Cause
The issue is triggered due to the SSL certificate used by Cognos Analytics Dispatcher being non-compliant with National Institute of Standards and Technology (NIST) Special Publication SP800-131 standards.
TM1 Server by default operates in compliance with National Institute of Standards and Technology (NIST) Special Publication SP800-131 hence the authentication request is rejected by the TM1 Server.
Resolving The Problem
The following parameter needs to be defined within tm1s.cfg file to avoid the log on failures.
NIST_SP800_131A_MODE=False
This is a static parameter and requires a TM1 Server restart to become effective, refer details below.
https://www.ibm.com/docs/en/planning-analytics/2.0.0?topic=pitf-nist-sp800-131a-mode
Related Information
Document Location
Worldwide
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Document Information
Modified date:
27 September 2021
UID
ibm16492949