Troubleshooting
Problem
When you run a Vulnerability Assessment ("Harden > Vulnerability Assessment > Assessment Builder"), no results are returned, but the Guardium™ Job Queue ("Harden > Vulnerability Assessment > Guardium Job Queue") shows the assessment was completed.
Symptom
When you check the result section of the desired Vulnerability Assessment, the report shows no results. However, it displays one message similar to the below.
RECOMMENDATION_TEXT: None of the tests in this assessment had the necessary data available to run to completion. Make sure the testing environment is configured correctly, and then run the assessment again. |
No tests ran to completion, therefore there is no overall score. Please check the execution log for configuration issues before re-running the assessment. |
Cause
There are no data sources configured for the Vulnerability Assessment.
Environment
Diagnosing The Problem
The correct troubleshooting is to verify the result log for the Assessment run (open the Security Assessment of interest from the "Harden > Vulnerability Assessment > Assessment Builder" menu of the GUI, then click on "View Results"), as it shows the data sources the tests were run against:
Irrespective of the slight differences in the view depending on the product version you are using, if the results view shows an empty list of data sources, that is the cause of the problem.
Resolving The Problem
1. Go to the Assessment builder GUI section ("Harden > Vulnerability Assessment > Assessment Builder").
2. Select the affected Vulnerability Assessment and click the "Edit selected Assessment" button ().
3. At the "Datasources" section of the "Security Assessment Builder" window, check what data sources are linked with the Security Assessment object. If it is empty, you are facing the issue.
Related Information
Document Location
Worldwide
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Document Information
Modified date:
18 October 2021
UID
ibm16486827