Troubleshooting
Problem
504 Gateway timeout error is thrown intermittently when navigating inside Cognos Administration Console
Symptom
When navigating inside Cognos Analytics Administration Console, especially the schedules tab, a 504 Gateway timeout error is thrown. This can also appear when using client tools.
Cause
This is not a Cognos Analytics issue, but an Apache Server issue. The environment might get busier than normal at times and can take longer to respond to requests. If Apache is using the default Timeout value, the 504 Gateway Timeout error will be thrown if the request takes longer.
Resolving The Problem
Disclaimer: This technote explains how to resolve an issue, which occurs due to missing configuration in software outside of scope of IBM and IBM Cognos Analytics. IBM is unable to provide support for third-party software such as Apache Server. Proceed with caution.
- Log on to the gateway server.
- Open the httpd.conf file in any text editor.
- Add the following derivative in the file:
- TimeOut Seconds
- Where Seconds is the number of seconds you want the request to be timed out after. For example: TimeOut 300
- Save the file and restart Apache server.
Related Information
Document Location
Worldwide
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Document Information
Modified date:
29 July 2022
UID
ibm16486395