Troubleshooting
Problem
Federated users from the UK are unable to authenticate to IBM Planning Analytics with Watson
Symptom
CSIAC6274E Authentication failed due to a configured policy
Cause
SAML trace shows all the necessary attributes are present: firstName, lastName, emailAddress, and country. However, country is returning a value of 'UK'. IBM Federation requires 'country' to follow ISO 3166 alpha 2 character code standards. In this case, 'GB' is the correct value.
Diagnosing The Problem
1) Gather a SAML trace to capture the SAML response
2) Verify the value passed back for 'country'
Resolving The Problem
Update 'country' from 'UK' to 'GB'
Related Information
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSD29G","label":"IBM Planning Analytics"},"ARM Category":[{"code":"a8m50000000L2eoAAC","label":"1 - Migrated Categories->BA - Planning Analytics Cloud->Federation"}],"ARM Case Number":"TS006594124","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]
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Document Information
Modified date:
26 August 2021
UID
ibm16484213