Troubleshooting
Problem
Uploading a new license file from the license consumption screen in Maximo Application Suite results in a CUDHT0003E error.
Symptom
The license fails to to upload and the following error is displayed on screen
WARNING AIUCL0002W: Received error from entitlement upload API: {"message":"CUDHT0003E: An IO error occurred while processing the response. If the error is "broken pipe" or "connection reset by peer", a possible cause is that the client issued an HTTP GET request but did not read the response. {0}.","exception":{"id":"CUDHT0003E","properties":[]}}
Cause
This can occur when a new license file is rejected and the RLKS pod reverts back to the previous and possibly expired license file.
Diagnosing The Problem
Review the coreapi and api-licensing logs, you may see the following errors.
api-licensing
[26/08/21 13:07:40:062 UTC] 000029d8 id=00000000 com.ibm.sls.internal.rlks.client.utils.Http E executeRequest Network failure: sls-rlks-0.rlks: sls-rlks-0.rlks: unknown error
coreapi
WARNING AIUCL0002W: Received error from entitlement upload API: {"message":"CUDHT0003E: An IO error occurred while processing the response. If the error is "broken pipe" or "connection reset by peer", a possible cause is that the client issued an HTTP GET request but did not read the response. {0}.","exception":{"id":"CUDHT0003E","properties":[]}}
Resolving The Problem
To resolve this issue you may need to the old license first before uploading the new one.
- Scale down the rlks pod
- When the pod is starting back up delete the license
'oc exec -ti sls-rlks-0 -- rm -rf /usr/local/flexlm/licenses/entitlement.lic'
- Log in to the map console with your super user and upload the new license file.
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSRHPA","label":"IBM Maximo Application Suite"},"ARM Category":[{"code":"a8m3p000000hAeeAAE","label":"Maximo Application Suite->Core"}],"ARM Case Number":"TS006610773","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]
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Document Information
Modified date:
25 October 2021
UID
ibm16484203