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Missing 'my folder' content after importing a Cognos deployment when using OIDC namespace

Question & Answer


Question

Why am i missing content information from user's 'my folders', after importing a Cognos deployment that includes user account information, when using an OIDC namespace?

Cause

During a deployment import, Cognos attempts to validate that the users exist, before moving content into their user container.
For Active Directory and LDAP namespaces, Cognos would perform a user lookup that uses the bind credentials from the configuration, in order to confirm whether the users exist.
For OIDC namespaces, there is no functionality to perform a user lookup. For this reason, Cognos will only be able to validate users who have previously logged in, or if they have previously created users by using the CSV import method.

Answer

Please create your users in Cognos by either having them log in first, or importing the user information from a CSV file. These steps are documented here:

[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m50000000Cl3zAAC","label":"Administration"}],"ARM Case Number":"TS006277529","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
21 August 2021

UID

ibm16482997