Troubleshooting
Problem
Planning Analytics Workspace is unable to connect to TM1 Server. The server is stuck on the loading icon in the server tree.
Cause
The issue occurs because Workspace is unable to connect to the TM1 Server due to the lack of the IPAddressV4 parameter in the tm1s.cfg file of the TM1 server. A physical server/host can have one internal IP address for clients within a firewall and a different external IP address for clients outside the firewall. By default, all TM1 client requests are routed through the external (public) adapter, which would require updates to firewall profiles. By assigning the internal IP address of the TM1 Server to the IPAddressV4 parameter, traffic is routed through the private adapter, and firewall profiles do not require updates.
Resolving The Problem
Add the IPAddressV4 parameter in the tm1s.cfg file of the TM1 Server and restart the TM1 Server.
IPAddressV4- https://www.ibm.com/docs/en/planning-analytics/2.0.0?topic=pitf-ipaddressv4
Document Location
Worldwide
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Document Information
Modified date:
09 August 2021
UID
ibm16479651