IBM Support

Search functionality not working in IM Cognos Analytics after upgrade or restart, seeing index.lock file in data/search/indices/cm/index

Troubleshooting


Problem

A Fix Pack was applied on top of the existing installation of IBM Cognos Analytics 11.0 After that, Search functionality stopped working.

Symptom

A file named index.lock file was found in data/search/indices/cm/index of the IBM Cognos Analytics Content Manager installation.

Cause

The the Content Manager processes was killed before applying the newer version of CA.
In IBM Cognos Analytics 11.0.13 Cognos Search makes use of Lucene third-party package to write to and read from index files. write.lock is a file used by Lucene to prevent simultaneous write operations. If the ongoing write operation is not completed and the process of the Content Manager is killed the index becomes inconsistent and unusable. In general, killing Cognos processes could cause various issues.

Resolving The Problem

Delete index files as described in https://www.ibm.com/support/pages/node/730183

Document Location

Worldwide

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Document Information

Modified date:
06 August 2021

UID

ibm16479369