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Control Center won't start due to CD_STATS_LOG SWITCH PARTITION issue

Troubleshooting


Problem

New install of Control Center was running for a while but then would no longer start.

Symptom

Control Center startup fails - in nohup.out
E R R O R
An error occurred while executing SQL command.
ALTER TABLE CD_STATS_LOG SWITCH PARTITION $PARTITION.CD_PART_FUNC('2021/06/17') TO TEMP_CD_STATS_LOG
SQL Error code = 4944
Error code : InstallErrorCodeList.4008
Error : ALTER TABLE SWITCH statement failed because column 'MEMBER_NAME' has data type nvarchar(255) in source table 'CD_STATS_LOG' which is different from its type varchar(9) in target table 'TEMP_CD_STATS_LOG'.

Cause

Found out there was a data masking product from Informatics in use. 

Diagnosing The Problem

Did the same command manually and see the issue
SELECT * INTO TEMP2_CD_STATS_LOG FROM CD_STATS_LOG WHERE 1 = 2
Compared data type of all columns in the two tables. After the SELECT INTO command, TEMP2_CD_STATS_LOG had 4 columns with a varchar(9) where as CD_STATS_LOG had nvarchar(255)
CD_STATS_LOG
MEMBER_NAME (nvarchar(255),null)
SOURCE_MEMBER_NAME (nvarchar(255),null)
TARGET_MEMBER_NAME (nvarchar(255),null)
ALIAS_MEMBER_NAME (nvarchar(255),null)
TEMP2_CD_STATS_LOG
MEMBER_NAME (varchar(9),null)
SOURCE_MEMBER_NAME (varchar(9),null)
TARGET_MEMBER_NAME (varchar(9),null)
ALIAS_MEMBER_NAME (varchar(9),null)

Resolving The Problem

After Informatics data masking was turned off the issue went away.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9GLA","label":"IBM Control Center"},"ARM Category":[{"code":"a8m0z000000cwVwAAI","label":"DATABASE"}],"ARM Case Number":"TS006302159","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"6.2.0;and future releases"}]

Document Information

Modified date:
29 July 2021

UID

ibm16476712