Troubleshooting
Problem
The Maximo Application Suite (MAS) 8.5 installer installs IBM Truststore Manager version 1.1.0 by default. However, this version requires a version of Java that's incompatible with other components required by or installed on top of MAS, and can result in errors accessing truststore files.
Symptom
If version 1.1.0 of IBM Truststore Manager is installed, you might encounter errors where components are not able to read p12 truststore files and failing to properly initialize.
Cause
IBM Truststore Manager version 1.1.0 requires a version of Java that is incompatible with other components that are required by or that are installed on top of Maximo Application Suite.
Environment
This only impacts users who install Maximo Application Suite by using the installer script. Operator Lifecycle Manager-based installations should not be affected as the latest version of truststore manager is always used by default.
Resolving The Problem
Before you run the Maximo Application Suite installer, set and export the following variable:
export TM_VERSION=1.1.1
After you have set the variable, continue with the Maximo Application Suite installation.
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSRHPA","label":"IBM Maximo Application Suite"},"ARM Category":[{"code":"a8m3p000000GoLBAA0","label":"Maximo Application Suite->Installation"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"8.5.0"}]
Was this topic helpful?
Document Information
Modified date:
29 July 2021
UID
ibm16476676