IBM Support

Advanced settings removed after restarting service

Question & Answer


Question

Why are the advanced settings missing after we restarted Cognos Analytics services?

Cause

Unregistered the dispatcher before restarting the Cognos Analytics dispatcher.

Answer

When a dispatcher is unregistered from an environment,  advanced settings or tuning settings set at the dispatcher level are removed.  You need to manually readd these settings.
A normal shutdown and restart of a dispatcher does not remove the dispatcher level advanced or tuning settings.
There is unfortunately no way to maintain the settings set at the dispatcher level when the dispatcher is unregistered from the environment.
Best practice is to set advanced parameters and tuning settings at the system level. Settings set at the system level are not removed when the dispatcher is unregistered.  When settings are set at the system level and the dispatcher settings are set to inherit from the parent level, they inherit the settings from the system level.

[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m50000000Cl3zAAC","label":"Administration"}],"ARM Case Number":"TS006169109","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
22 July 2021

UID

ibm16474537