IBM Support

Unable to get RPC handle to view error during checkin

Troubleshooting


Problem

The following error might occur during checkin in a web or automatic view:
  CRMAP7009: Command "CCW_CCase::checkin_rpc" failed: CRMSV1070: Unable to get RPC handle to view

Symptom

An attempt to check in a file version whose size exceeds 2 gigabytes (GB) from a ClearCase web or automatic view fails with the following error:
% rcleartool ci -nc /vobs/myvob/largefile
CRMAP7009: Command "CCW_CCase::checkin_rpc" failed: CRMSV1070: Unable to get RPC handle to view "my_automatic_view": ClearCase object not found
This behavior applies to checkin operations in ClearTeam Explorer as well.

Cause

A web or automatic view is being used for the checkin operation and the file version container size exceeds 2 GB. Note that the actual 2 GB limitation value might vary slightly based upon your OS platform. Neither web nor automatic views support manipulation of files greater than 2 GB.

Resolving The Problem

Both dynamic and snapshot views in ClearCase support handling of files greater than 2 GB for appropriate type managers. Use one of these view types instead.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSSH27","label":"Rational ClearCase"},"ARM Category":[{"code":"a8m0z000000boFtAAI","label":"ClearCase->CCRC"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
26 July 2021

UID

ibm16474239