Troubleshooting
Problem
User launches FAP client ("IBM Cognos FAP") from the start menu. User logs on. User clicks tab 'data marts' and highlights the relevant data mart. User clicks "Start" (to start the initial publish).
After a few seconds, the 'status' changes to 'Error'. User clicks the 'logs' tab. Inside there, there is a ‘CRITICAL’ error saying “Could not login to TM1”
If the user hovers their mouse over that error, a new pop-up message is seen:
SystemServerClientNotFound
In the FAP server's 'error.log' file (default location here: C:\Program Files\ibm\cognos\ccr_64\Server\FAP) there is the following entry:
11:59:27,018 | ERROR [fap.service.schedule.Scheduler] [schedulerThread], Could not logon to TM1
com.ibm.cognos.tm1.TM1Exception: SystemServerClientNotFound
at com.ibm.cognos.fap.common.persistence.tm1.TM1Context.login(TM1Context.java:124)
at com.ibm.cognos.fap.service.schedule.Scheduler.updateDatamarts(Scheduler.java:591)
at com.ibm.cognos.fap.service.schedule.Scheduler.run(Scheduler.java:261)
at com.ibm.cognos.fap.service.schedule.Scheduler$1.run(Scheduler.java:166)
at java.lang.Thread.run(Thread.java:822)
Cause
There are many possible causes for similar errors. For more examples, see IBM technote 408569 here:
https://www.ibm.com/support/pages/node/408569
https://www.ibm.com/support/pages/node/408569
This document relates to the scenario where the cause is that the TM1 API (TM1 SDK / TM1 REST API) that FAP uses (to connect to TM1 cannot access to Cognos Analytics server namespace, using CAM security) cannot connect because the Windows user account running the Cognos Analytics service ("IBM Cognos") does not have the required rights.
- In other words, the 'IBM Cognos' service is running under a user account with restricted rights.
Tip: For more information, see IBM technote 528137 here:
https://www.ibm.com/support/pages/node/528137
Environment
This problem might affect any environment, but it was seen with:
- Controller 10.4.2 IF10
- Planning Analytics 2.0.9.8
- Cognos Analytics 11.1.7 RTM
- Controller 10.4.2 IF10
- Planning Analytics 2.0.9.8
- Cognos Analytics 11.1.7 RTM
Resolving The Problem
Modify the user account used to run the Windows service "IBM Cognos" so that:
1. It has all of the following rights (on the CA server):
1. It has all of the following rights (on the CA server):
- Act as part of the operating system
- Log on as a service
2. It is a member of the local "Administrators" Windows security group (on the Cognos Analytics server)
Steps:
On the CA server:
- Launch Windows Administration Tools
- Open "Local Security Policy"
- Open "Local Policies" – "User Rights Assignment"
- Assign the relevant user the correct rights:
Steps:
On the CA server:
- Launch Windows Administration Tools
- Open "Local Security Policy"
- Open "Local Policies" – "User Rights Assignment"
- Assign the relevant user the correct rights:
- Act as part of the operating system
- Log on as a service
- Finally, add that user account to the local 'Administrators' group.
Workaround:
Workaround:
In one real-life example, a workaround was to change the Windows service "IBM Cognos" (on the CA server) from running as a domain user 'service account' to instead run as 'Local System'.
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"ARM Category":[{"code":"a8m3p000000GoPrAAK","label":"Controller"}],"ARM Case Number":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.4.2"}]
Was this topic helpful?
Document Information
Modified date:
11 July 2021
UID
ibm16470933