Troubleshooting
Problem
After being idle for a period of time, the following error is displayed and the DOORS client exits:
The connection with the database server has been lost and reconnection attempts have failed.
This may be due to network problems or the server may have been stopped.
This may be due to network problems or the server may have been stopped.
DOORS will now exit.
Symptom
When this error occurs to a DOORS client, the DOORS server is still running and all other DOORS clients still work.
Cause
There is network policy where an inactive TCP connection will be disconnected after a pre-defined period of time (for example 2 hours).
Resolving The Problem
Ask network administrator to check the policy for inactive TCP/IP connections
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSKR2T","label":"IBM Engineering Requirements Management DOORS"},"ARM Category":[{"code":"a8m50000000CiqLAAS","label":"DOORS->Client"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]
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Document Information
Modified date:
08 July 2021
UID
ibm16470565