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Error 'Initialize Project Area' failed when creating a project in IBM Engineering Workflow Management

Troubleshooting


Problem

You receive error 'Initialize Project Area' failed when you create and save a project in IBM Engineering Workflow Management (EWM). This error occurs when the project is created either from the out of the box or custom templates.

Symptom

The following error occurs upon saving a newly created project in EWM.
Project area cannot be saved.
'Initialize Project Area' failed.
NOTE: The user is assigned the EWM developer license and has one or more repository roles.

Cause

The Rhapsody Model Manager(RMM) is installed in "Model Management Server" mode and the user does not have RMM licenses assigned.
Starting in RMM v7.0, RMM can be installed as an extension to EWM. There are two different server deployment modes - Model Management and Model and Code Management.
When RMM is installed in "Model Management Server" mode, it entitles you to perform configuration management operations on your Rhapsody models but not on code or any other artifacts. All projects created in the application are RMM projects and require an RMM license.
For more information, see Licensing for Rhapsody Model Manager

Environment

EWM 7.0.x with IBM Rhapsody Model Manager (RMM) installed in "Model Management Server" mode.

Diagnosing The Problem

Review ccm.log for error CRJAZ1848E. Note the operation ID "com.ibm.rmm.scm.server.createPersonalWorkspace" is an RMM operation.
2021-06-28 14:08:40,420 [Default Executor-thread-943 @@ 14:00 <user id> <Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:88.0) Gecko/20100101 Firefox/88.0@9.160.88.64> /ccm/service/com.ibm.team.process.internal.service.web.IProcessWebUIService/projectArea] ERROR com.ibm.team.process.common                        [TID: 65D28B68] - CRJAZ2675I A client action caused the server exception that is listed below. The identifier for the error is fbf8b6e4-6574-4127-a424-d4a36d7a224d.
com.ibm.team.repository.common.LicenseNotGrantedException: Unable to obtain license to create a repository workspace: An error response was received from the Jazz Team Server. Status=400.  Message: CRJAZ1848E To perform the "com.ibm.rmm.scm.server.createPersonalWorkspace" operation, the user (userid=“<user id>”) must have one of the following licenses that are installed on the server: IBM Engineering Systems Design Rhapsody - Model Manager.Systems and Software Engineer. The server administrator can assign licenses.

Resolving The Problem

Review and ensure that RMM is installed in the correct mode.
  • For RMM installed in the "Model Management Server" mode, ensure that the user is assigned an RMM license.
  • If the mode is "Mode and Code Management", but RMM is installed in the "Model Management Server" mode, you can change the "Rhapsody Model Manager Deployment Mode" from "model" to "model_and_code". See Upgrading the server deployment mode to Model and Code Management

Document Location

Worldwide

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Product Synonym

RMM; EWM

Document Information

Modified date:
29 June 2021

UID

ibm16467731