IBM Support

Cognos Analytics website is not responding and eventually returns with "HTTP Error 502"

Troubleshooting


Problem

Cognos Analytics website is not responding and eventually returns with "HTTP Error 502"
No access to the site is possible. 

Symptom

The application URL is working and access is fine. (http:server:9300/bi)

Cause

The IIS rewrite rules are not routing requests appropriately.
The Reverse Proxy rule is using the incorrect protocol.   Https vs http

Environment

Windows install that uses IIS

Resolving The Problem

To resolve the matter, ensure that the protocol used by the application (HTTP or HTTPS) is used in the Reverse Proxy rule. 
e.g. application URL: http:server:9300/bi -- Rewrite url should be : http://<server>:9300/bi/{R:0} or http://ca_server/bi/ (if using server farm)
https:server:9300/bi -- Rewrite url should be: https://<server>:9300/bi/{R:0} or https://ca_server/bi/ (if using server farm)
Once the change is made, apply the change and recycle the IIS application pool.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m50000000Cl6iAAC","label":"Installation and Configuration->Gateway"}],"ARM Case Number":"TS006007718","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
03 September 2021

UID

ibm16467149